DNS Issues
Incident Report for Teespring
Resolved
DNS appears to be behaving normally across the Internet
Posted Oct 21, 2016 - 22:53 UTC
Monitoring
We've re-routed around the current DNS issues and the site is operating as we would expect. We're currently monitoring all of our services.
Posted Oct 21, 2016 - 19:45 UTC