Images Not Loading
Incident Report for Teespring
Resolved
Images on Teespring should be served correctly now.
Posted Aug 08, 2016 - 19:38 UTC
Identified
We're currently seeing elevated error rates for shirt images on Teespring.com. We've identified the issue as a bad load balancer and are working to resolve the issue.
Posted Aug 08, 2016 - 18:39 UTC