Cache server problem causing teespring.com to be unavailable
Incident Report for Teespring
Resolved
The caching infrastructure is fixed and the site is back up. In total, the site was semi-functional for 10 minutes – our apologies for the problem, we will conduct a post-mortem investigation.
Posted Nov 23, 2020 - 07:23 UTC
Identified
We have identified a problem with caching infrastructure on teespring.com which is causing availability problems on our site.
Posted Nov 23, 2020 - 07:12 UTC
This incident affected: teespring.com.