Cloudflare network problems in Europe
Incident Report for Teespring
Resolved
This incident has been resolved.
Posted Jun 20, 2016 - 14:14 UTC
Monitoring
Cloudflare's network seems to have stabilised in Europe (although they've not yet updated their status page).

Monitoring.
Posted Jun 20, 2016 - 13:03 UTC
Update
This problem is much more marked in Europe than elsewhere. No reported problems in US or Asia.
Posted Jun 20, 2016 - 12:43 UTC
Identified
We run a lot of our traffic through Cloudflare, for performance and security reasons.

Unfortunately, they're having network problems at the moment: https://www.cloudflarestatus.com/
Posted Jun 20, 2016 - 12:41 UTC