Problems with the checkout page on Teespring
Incident Report for Teespring
Resolved
This incident has been resolved.
Posted Sep 20, 2019 - 11:24 UTC
Monitoring
Our first fix was successful, after clearing some intermediate caches which were poisoned with bad data. Everything is 100% functional on teespring.com again but we'll monitor for any further problems.

Our apologies for the inconvenience caused!
Posted Sep 19, 2019 - 21:12 UTC
Identified
A mismatch between the backend code and the frontend assets being used seems to be the underlying issue here.

We have two fixes being worked on in parallel. One of which is to push a new version of the backend code up to match the frontend code (ETA: 5 minutes), the other fix is to expire all caching around our frontend assets (ETA: 45 minutes).
Posted Sep 19, 2019 - 20:44 UTC
Investigating
We are investigating a problem with buyers being able to buy from some listings on teespring.com.

At the moment, about 12% of attempts to start a checkout process are failing.

This is our absolute top priority to investigate and fix – we will update this issue as we know more.
Posted Sep 19, 2019 - 19:54 UTC
This incident affected: teespring.com.