teespring.com unavailable
Incident Report for Teespring
Resolved
Everything is stabilised and working normally.
Posted Feb 20, 2018 - 16:06 UTC
Identified
Our master database had connection problems. We have restarted the instance and believe things are normalised: double checking everything now.
Posted Feb 20, 2018 - 15:53 UTC
Investigating
We are currently investigating this issue.
Posted Feb 20, 2018 - 15:40 UTC