Slowness saving design assets with our infrastructure provider: affecting design launcher tools
Incident Report for Teespring
Resolved
As of 30 minutes ago, we finally finished processing the backlog of work to save and process design assets.

Teespring.com is 100% functional and at full-speed once again.

Our sincere apologies for the delay here – we had a couple of early indicators that a solution was very close, which turned out not to be the case.
Posted Sep 04, 2019 - 17:47 UTC
Update
The fix we have planned for the image processing dependency has taken longer to prepare and deploy due to a limitation in another infrastructure provider.

We are working with their support team as a top priority to resolve the issue – will update here as we have more news.
Posted Sep 03, 2019 - 19:55 UTC
Identified
We now believe that an underlying image processing dependency was misconfigured in our platform. We're building out new images with corrected configuration, which will be live in about 45 minutes.

At that point, we'll be monitoring the issue, and will update here with an estimate on how long it will take to get back to 100% normal function.
Posted Sep 03, 2019 - 13:46 UTC
Investigating
We are seeing degraded performance when we are saving the assets which form users' designs. This applies to both the Launcher (new tool) and Composer (legacy tool).

Currently investigating this slowness and working with AWS – our infrastructure provider – to get an estimate on a resolution.
Posted Sep 03, 2019 - 09:13 UTC
This incident affected: teespring.com and Image processing.