Teespring.com unavailable due infrastructure failures
Incident Report for Teespring
Resolved
This incident has been resolved.
Posted Jul 25, 2020 - 02:40 UTC
Update
A change to our infrastructure failed to complete successfully – leading to teespring.com being unavailable. We are working with our support team at AWS to understand what the underlying problem was.

Until we understand that we won't be making any further infrastructure changes.
Posted Jul 25, 2020 - 02:39 UTC
Update
We are continuing to investigate this issue.
Posted Jul 25, 2020 - 01:23 UTC
Update
Teespring.com is back up; we are investigating and monitoring.
Posted Jul 25, 2020 - 01:23 UTC
Investigating
We are currently investigating this issue.
Posted Jul 25, 2020 - 01:15 UTC
This incident affected: teespring.com and API.