Slowness and errors across teespring.com
Incident Report for Teespring
Resolved
This incident has been resolved.
Posted Sep 03, 2019 - 09:11 UTC
Monitoring
It's unclear if the underlying AWS problem is getting resolved, or if our workaround is effective. Either way, the health checks are _almost_ back to normal levels now – all seller and buyer activity on teespring.com is working as expected.

We're continuing to monitor closely until the error rates have been stable at their current levels for a while.
Posted Aug 31, 2019 - 17:25 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 31, 2019 - 17:03 UTC
Identified
Due to a problem with AWS – our infrastructure provider – we have noticed some slowness and elevated error rates across Teespring.

The AWS problem is described here: https://status.aws.amazon.com

We have identified a temporary workaround for the problem, which is rolling out now and should help with the site speed.
Posted Aug 31, 2019 - 17:02 UTC
This incident affected: teespring.com and AWS EC2.