Teespring.com is not reachable, returning 502 errors.
Incident Report for Teespring
Resolved
Cloudflare seems to be operational again. Everything should be working normally. If there’s any issues, please let us know.
Posted Jul 02, 2019 - 14:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 02, 2019 - 14:07 UTC
Monitoring
Our vendor, Cloudflare is currently experiencing issues in the US. As a result, a number of systems are down. We’re tracking the status and will update as we get more info.
Posted Jul 02, 2019 - 14:07 UTC
This incident affected: teespring.com, Image processing, API, and CloudFlare CloudFlare.com.