Payouts tab not working for some sellers
Incident Report for Teespring
Resolved
We've just pushed out a fix which resolves the degraded performance on the payout tab
Posted Apr 15, 2016 - 01:11 UTC
Identified
A recent update to one of our web frameworks introduced an obscure performance regression which is affecting the payouts tab for our heaviest users.

We working on patching this framework right now. ETA is hard to predict with this kind of thing, but will be measured in hours rather than minutes or days.
Posted Apr 14, 2016 - 19:29 UTC
Investigating
Buyer activity not affected. Currently investigating and will update as we learn more.
Posted Apr 14, 2016 - 17:27 UTC