Cloudflare network issues
Incident Report for Teespring
Resolved
We haven't seen any lingering problems from the earlier Cloudflare outage.

Our apologies for any inconvenience caused by this problem!
Posted Jul 02, 2019 - 15:00 UTC
Monitoring
Cloudflare claim to have fixed the issue on their side. We are seeing web traffic return to normal patterns on our side.

We will leave this incident open for 30 minutes or so to be safe, but teespring.com should be back to normal at this point.
Posted Jul 02, 2019 - 14:30 UTC
Identified
Teespring uses Cloudflare, but unfortunately they are having network problems.

You can track their status here: https://www.cloudflarestatus.com/

We will update here as we have more information. The symptoms you may expect to see in the meantime are 502 errors as you browse teespring.com.
Posted Jul 02, 2019 - 14:23 UTC
This incident affected: CloudFlare CloudFlare.com.