Degraded response times
Incident Report for Teespring
Resolved
This incident has been resolved.
Posted Nov 03, 2016 - 08:36 UTC
Investigating
We are currently investigating intermittent reports of slow site response times.
Posted Nov 03, 2016 - 02:24 UTC