Load problems causing slowness and timeout errors
Incident Report for Teespring
Resolved
This incident has been resolved.
Posted Aug 31, 2019 - 16:18 UTC
Update
All systems have been stable since our last update, but we'll leave this incident open until we fully understand the underlying problem and ensure we're covered against the same problem happening again.
Posted Jul 26, 2019 - 11:27 UTC
Monitoring
The traffic spike has normalised. We are watching closely for subsequent spikes in the traffic volume – but for right now everything is back to normal on teespring.com.

We will update here if anything changes, and with a resolution once we understand the underlying root cause.
Posted Jul 25, 2019 - 19:20 UTC
Investigating
Due to a huge spike in traffic to one of our endpoints which is used during launching a listing, our site is experiencing performance and availability problems.

We will update here as we make progress understanding and addressing the issue.
Posted Jul 25, 2019 - 19:09 UTC
This incident affected: teespring.com and Image processing.